$re = '/^(?:\d+(?::[0-5][0-9]:[0-5][0-9])?|[0-5]?[0-9]:[0-5][0-9])$/m';
$str = '1:01:12
3
1233:23:45
2:59:59
34:34
1234
99
59:59
6:12
59:60
2:59:60
6:
1:1:12
2:59:59:45
66:12
1:1:12';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);