package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:\d+(?::[0-5][0-9]:[0-5][0-9])?|[0-5]?[0-9]:[0-5][0-9])$`)
var str = `1:01:12
3
1233:23:45
2:59:59
34:34
1234
99
59:59
6:12
59:60
2:59:60
6:
1:1:12
2:59:59:45
66:12
1:1:12`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}