// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:\d+(?::[0-5][0-9]:[0-5][0-9])?|[0-5]?[0-9]:[0-5][0-9])$").unwrap();
let string = "1:01:12
3
1233:23:45
2:59:59
34:34
1234
99
59:59
6:12
59:60
2:59:60
6:
1:1:12
2:59:59:45
66:12
1:1:12";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}