using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d+(?:\.\d+)*[\s\S]*?\D(?=\s*(?:\d|$))";
string input = @"1.1. FLESH; 1.1.2. BRAIN; 2. BRAIN.
1.1. FLESH
1.1.2. BRAIN
2. BRAIN";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}