re = /\d+(?:\.\d+)*[\s\S]*?\D(?=\s*(?:\d|$))/m
str = '1.1. FLESH; 1.1.2. BRAIN; 2. BRAIN.
1.1. FLESH
1.1.2. BRAIN
2. BRAIN'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end