import re
regex = re.compile(r"\d+(?:\.\d+)*[\s\S]*?\D(?=\s*(?:\d|$))", flags=re.MULTILINE)
test_str = ("1.1. FLESH; 1.1.2. BRAIN; 2. BRAIN.\n"
"1.1. FLESH\n"
"1.1.2. BRAIN\n"
"2. BRAIN")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")