$re = '/\d+(?:\.\d+)*[\s\S]*?\D(?=\s*(?:\d|$))/m';
$str = '1.1. FLESH; 1.1.2. BRAIN; 2. BRAIN.
1.1. FLESH
1.1.2. BRAIN
2. BRAIN';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);