#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)//[^/]+(/[^/]+/[^/]+/).*"
Local $sString = "//localhost:8000/foo/pml/vault/" & @CRLF & _
"//localhost:8000/bar/bom/vault/" & @CRLF & _
"//localhost:8000/baz/parts/advancedsearch/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")