re = /\/\/[^\/]+(\/[^\/]+\/[^\/]+\/).*/m
str = '//localhost:8000/foo/pml/vault/
//localhost:8000/bar/bom/vault/
//localhost:8000/baz/parts/advancedsearch/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end