package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)//[^/]+(/[^/]+/[^/]+/).*`)
var str = `//localhost:8000/foo/pml/vault/
//localhost:8000/bar/bom/vault/
//localhost:8000/baz/parts/advancedsearch/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}