using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"//[^/]+(/[^/]+/[^/]+/).*";
string input = @"//localhost:8000/foo/pml/vault/
//localhost:8000/bar/bom/vault/
//localhost:8000/baz/parts/advancedsearch/";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}