using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:\/[^\/\n]*){2}(?:\/tree(?:\/[^\/\n]*)*)?$";
string input = @"/foo/bar
/foo/bar/tree/baz
/foo/bar/tree/baz/foobar
/foo/bar/blob
/foo/bar/blob/x.js";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}