const regex = /^(?:\/[^\/\n]*){2}(?:\/tree(?:\/[^\/\n]*)*)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:\\\/[^\\\/\\n]*){2}(?:\\\/tree(?:\\\/[^\\\/\\n]*)*)?$', 'gm')
const str = `/foo/bar
/foo/bar/tree/baz
/foo/bar/tree/baz/foobar
/foo/bar/blob
/foo/bar/blob/x.js`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}