re = /^(?:\/[^\/\n]*){2}(?:\/tree(?:\/[^\/\n]*)*)?$/m
str = '/foo/bar
/foo/bar/tree/baz
/foo/bar/tree/baz/foobar
/foo/bar/blob
/foo/bar/blob/x.js'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end