$re = '/^(?:\/[^\/\n]*){2}(?:\/tree(?:\/[^\/\n]*)*)?$/m';
$str = '/foo/bar
/foo/bar/tree/baz
/foo/bar/tree/baz/foobar
/foo/bar/blob
/foo/bar/blob/x.js';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);