#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([abc])([de])\2\1"
Local $sString = "12%" & @CRLF & _
"ab" & @CRLF & _
"adda" & @CRLF & _
"abcc" & @CRLF & _
"abccc" & @CRLF & _
"ab abc " & @CRLF & _
"abceec" & @CRLF & _
"abccccc" & @CRLF & _
"abcccccc" & @CRLF & _
"abcceeccbac" & @CRLF & _
"abcd abc abcde" & @CRLF & _
"abcbcbcbcbcbc" & @CRLF & _
"abc" & @CRLF & _
"- _ { } @ " & @CRLF & _
"3%"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")