using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([abc])([de])\2\1";
string input = @"12%
ab
adda
abcc
abccc
ab abc
abceec
abccccc
abcccccc
abcceeccbac
abcd abc abcde
abcbcbcbcbcbc
abc
- _ { } @
3%";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}