re = /([abc])([de])\2\1/m
str = '12%
ab
adda
abcc
abccc
ab abc
abceec
abccccc
abcccccc
abcceeccbac
abcd abc abcde
abcbcbcbcbcbc
abc
- _ { } @
3%'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end