$re = '/([abc])([de])\2\1/m';
$str = '12%
ab
adda
abcc
abccc
ab abc
abceec
abccccc
abcccccc
abcceeccbac
abcd abc abcde
abcbcbcbcbcbc
abc
- _ { } @
3%';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);