#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<AccountNumber>(\d{12})"
Local $sString = "<ns2:PaymentMethod>" & @CRLF & _
" <CCInfo xmlns="">" & @CRLF & _
" <AccountType>sdaj</AccountType>" & @CRLF & _
" <AccountNumber>1234567890123456</AccountNumber>" & @CRLF & _
" <AccountName>sdfsad</AccountName>" & @CRLF & _
" <ExpirationMonth>sdaf</ExpirationMonth>" & @CRLF & _
" <ExpirationYear>afgds</ExpirationYear>" & @CRLF & _
" </CCInfo>" & @CRLF & _
" </ns2:PaymentMethod>" & @CRLF & _
" <ns2:PaymentMethod>" & @CRLF & _
" <CCInfo xmlns="">" & @CRLF & _
" <AccountType>kyfkuk</AccountType>" & @CRLF & _
" <AccountNumber>098765432123987</AccountNumber>" & @CRLF & _
" <AccountName>hjvkv</AccountName>" & @CRLF & _
" <ExpirationMonth>gfdgh</ExpirationMonth>" & @CRLF & _
" <ExpirationYear>tdjk</ExpirationYear>" & @CRLF & _
" </CCInfo>" & @CRLF & _
" </ns2:PaymentMethod>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")