$re = '/<AccountNumber>(\d{12})/';
$str = '<ns2:PaymentMethod>
<CCInfo xmlns="">
<AccountType>sdaj</AccountType>
<AccountNumber>1234567890123456</AccountNumber>
<AccountName>sdfsad</AccountName>
<ExpirationMonth>sdaf</ExpirationMonth>
<ExpirationYear>afgds</ExpirationYear>
</CCInfo>
</ns2:PaymentMethod>
<ns2:PaymentMethod>
<CCInfo xmlns="">
<AccountType>kyfkuk</AccountType>
<AccountNumber>098765432123987</AccountNumber>
<AccountName>hjvkv</AccountName>
<ExpirationMonth>gfdgh</ExpirationMonth>
<ExpirationYear>tdjk</ExpirationYear>
</CCInfo>
</ns2:PaymentMethod>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);