import re
regex = re.compile(r"<AccountNumber>(\d{12})")
test_str = ("<ns2:PaymentMethod>\n"
" <CCInfo xmlns=\"\">\n"
" <AccountType>sdaj</AccountType>\n"
" <AccountNumber>1234567890123456</AccountNumber>\n"
" <AccountName>sdfsad</AccountName>\n"
" <ExpirationMonth>sdaf</ExpirationMonth>\n"
" <ExpirationYear>afgds</ExpirationYear>\n"
" </CCInfo>\n"
" </ns2:PaymentMethod>\n"
" <ns2:PaymentMethod>\n"
" <CCInfo xmlns=\"\">\n"
" <AccountType>kyfkuk</AccountType>\n"
" <AccountNumber>098765432123987</AccountNumber>\n"
" <AccountName>hjvkv</AccountName>\n"
" <ExpirationMonth>gfdgh</ExpirationMonth>\n"
" <ExpirationYear>tdjk</ExpirationYear>\n"
" </CCInfo>\n"
" </ns2:PaymentMethod>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")