import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<AccountNumber>(\\d{12})";
final String string = "<ns2:PaymentMethod>\n"
+ " <CCInfo xmlns=\"\">\n"
+ " <AccountType>sdaj</AccountType>\n"
+ " <AccountNumber>1234567890123456</AccountNumber>\n"
+ " <AccountName>sdfsad</AccountName>\n"
+ " <ExpirationMonth>sdaf</ExpirationMonth>\n"
+ " <ExpirationYear>afgds</ExpirationYear>\n"
+ " </CCInfo>\n"
+ " </ns2:PaymentMethod>\n"
+ " <ns2:PaymentMethod>\n"
+ " <CCInfo xmlns=\"\">\n"
+ " <AccountType>kyfkuk</AccountType>\n"
+ " <AccountNumber>098765432123987</AccountNumber>\n"
+ " <AccountName>hjvkv</AccountName>\n"
+ " <ExpirationMonth>gfdgh</ExpirationMonth>\n"
+ " <ExpirationYear>tdjk</ExpirationYear>\n"
+ " </CCInfo>\n"
+ " </ns2:PaymentMethod>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}