using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"BEGIN(?:(?!END)[\s\S])*EXCEPTION";
string input = @"BEGIN
xxx
END;
BEGIN
xxx
EXCEPTION
xxx
END;
BEGIN
xxx
EXCEPTION
xxx
END;";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}