re = /BEGIN(?:(?!END)[\s\S])*EXCEPTION/m
str = 'BEGIN
xxx
END;
BEGIN
xxx
EXCEPTION
xxx
END;
BEGIN
xxx
EXCEPTION
xxx
END;'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end