import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "BEGIN(?:(?!END)[\\s\\S])*EXCEPTION";
final String string = "BEGIN\n"
+ " xxx\n"
+ "END;\n"
+ "BEGIN\n"
+ " xxx\n"
+ "EXCEPTION\n"
+ " xxx\n"
+ "END;\n"
+ "BEGIN\n"
+ " xxx\n"
+ "EXCEPTION\n"
+ " xxx\n"
+ "END;";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}