using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"href=""[^""]*?\.pdf";
string input = @"<a href=""test.html"">test1</a>
<a href=""test.pdf"">test2</a>
<a href=""test.html"">test1</a>
<a href=""test.html"">test1</a><a href=""testtime.pdf"">test2</a>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}