re = /href="[^"]*?\.pdf/
str = '<a href="test.html">test1</a>
<a href="test.pdf">test2</a>
<a href="test.html">test1</a>
<a href="test.html">test1</a><a href="testtime.pdf">test2</a>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end