const regex = /\/\/([\w.-]+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/\\\/([\\w.-]+)', 'g')
const str = `<iframe id="donato-if" src="https://site.org/includes/donate.php?as_page=1&platform=wb&referer=http%3A//site2.org/web/20130129160928/http%3A//site3.ru/2005/10/29/prostranstvo-intellekta/"
<a href="https://site4.ru/lalala/http://site5.ru/" rel="external nofollow" class="url">lalala</a>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}