import re
regex = re.compile(r"\/\/([\w.-]+)")
test_str = ("<iframe id=\"donato-if\" src=\"https://site.org/includes/donate.php?as_page=1&platform=wb&referer=http%3A//site2.org/web/20130129160928/http%3A//site3.ru/2005/10/29/prostranstvo-intellekta/\"\n\n"
"<a href=\"https://site4.ru/lalala/http://site5.ru/\" rel=\"external nofollow\" class=\"url\">lalala</a>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")