using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\w+@.+?(?=""|\s)|(?<=""phone"":"")\d+";
string substitution = @"*******";
string input = @"""email"":""testEmail@test.com"", ""phone"":""1111111111"", ""text"":""sample text may contain email testEmail@test.com as well""";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}