re = /\w+@.+?(?="|\s)|(?<="phone":")\d+/m
str = '"email":"testEmail@test.com", "phone":"1111111111", "text":"sample text may contain email testEmail@test.com as well"'
subst = '*******'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result