use strict;
my $str = '"email":"testEmail@test.com", "phone":"1111111111", "text":"sample text may contain email testEmail@test.com as well"';
my $regex = qr/\w+@.+?(?="|\s)|(?<="phone":")\d+/mp;
my $subst = '*******';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";