#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<start>^[0-9]+)(?<message>[A-Za-z]+)(?<end>[^A-Za-z]*)$"
Local $sString = "1234test4321" & @CRLF & _
"4" & @CRLF & _
"0000oooo0000" & @CRLF & _
"4" & @CRLF & _
"Over!" & @CRLF & _
"" & @CRLF & _
"1wat!" & @CRLF & _
"3" & @CRLF & _
"#23asd33" & @CRLF & _
"3" & @CRLF & _
"333asd3a" & @CRLF & _
"3" & @CRLF & _
"100dun2" & @CRLF & _
"3" & @CRLF & _
"Over!" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")