// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?<start>^[0-9]+)(?<message>[A-Za-z]+)(?<end>[^A-Za-z]*)$").unwrap();
let string = "1234test4321
4
0000oooo0000
4
Over!
1wat!
3
#23asd33
3
333asd3a
3
100dun2
3
Over!
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}