#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[A-Za-z][A-Za-z0-9_]{0,39}$"
Local $sString = "Invalid:" & @CRLF & _
"4foo" & @CRLF & _
"foo bar" & @CRLF & _
"foo$@bar" & @CRLF & _
"" & @CRLF & _
"Valid:" & @CRLF & _
"" & @CRLF & _
"foo" & @CRLF & _
"foo_bar" & @CRLF & _
"Foo_Bar"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")