$re = '/^[A-Za-z][A-Za-z0-9_]{0,39}$/m';
$str = 'Invalid:
4foo
foo bar
foo$@bar
Valid:
foo
foo_bar
Foo_Bar';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);