// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[A-Za-z][A-Za-z0-9_]{0,39}$").unwrap();
let string = "Invalid:
4foo
foo bar
foo$@bar
Valid:
foo
foo_bar
Foo_Bar";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}