package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Za-z][A-Za-z0-9_]{0,39}$`)
var str = `Invalid:
4foo
foo bar
foo$@bar
Valid:
foo
foo_bar
Foo_Bar`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}