using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(=>)\s*(?![^\{]*\})";
string input = @"name => '=>'
(name) => {...}
name => ({..})
function() { return '=>'; }
function(name) { return () => {}}
(name, age) => doSomething('ff')
name => doSomething(() => {})";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}