$re = '/(=>)\s*(?![^\{]*\})/';
$str = 'name => \'=>\'
(name) => {...}
name => ({..})
function() { return \'=>\'; }
function(name) { return () => {}}
(name, age) => doSomething(\'ff\')
name => doSomething(() => {})';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);