re = /(=>)\s*(?![^\{]*\})/
str = 'name => \'=>\'
(name) => {...}
name => ({..})
function() { return \'=>\'; }
function(name) { return () => {}}
(name, age) => doSomething(\'ff\')
name => doSomething(() => {})'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end