import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(=>)\\s*(?![^\\{]*\\})";
final String string = "name => '=>'\n"
+ "(name) => {...}\n"
+ "name => ({..})\n"
+ "function() { return '=>'; }\n"
+ "function(name) { return () => {}}\n"
+ "(name, age) => doSomething('ff')\n"
+ "name => doSomething(() => {})";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}