using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\+\d{1,3}\s*\(?\d{3,6}\)?\s*[\d\-\s]{4,9}$";
string input = @"+7 (903) 758-6666";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}