// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\+\d{1,3}\s*\(?\d{3,6}\)?\s*[\d\-\s]{4,9}$").unwrap();
let string = "+7 (903) 758-6666";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}