const regex = new RegExp('^\\+\\d{1,3}\\s*\\(?\\d{3,6}\\)?\\s*[\\d\\-\\s]{4,9}$', 'gm')
const str = `+7 (903) 758-6666`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}