use strict;
my $str = 'a
b
c
d
e';
my $regex = qr/.*/mp;
my $subst = 'test';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";