import re
regex = re.compile(r".*", flags=re.MULTILINE)
test_str = ("a\n"
"b\n"
"c\n"
"d\n"
"e")
subst = "test"
result = regex.sub(subst, test_str)
if result:
print(result)