#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=,\s)([A-Z].*?)(?=[,\s]*[A-Z]{2}[,\s]*\d{5}(?:-\d{4})?)"
Local $sString = "123 Main St, Los Angeles, CA, 90210" & @CRLF & _
"123 Main St, North Las Vegas NV, 90210" & @CRLF & _
"123 Main St, Winston–Salem NC, 90210" & @CRLF & _
"123 Main St, St. Petersburg PA 90210-1111" & @CRLF & _
"123 Main St, Port St. Lucie PA 90210-1111"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")