$re = '/(?<=,\s)([A-Z].*?)(?=[,\s]*[A-Z]{2}[,\s]*\d{5}(?:-\d{4})?)/m';
$str = '123 Main St, Los Angeles, CA, 90210
123 Main St, North Las Vegas NV, 90210
123 Main St, Winston–Salem NC, 90210
123 Main St, St. Petersburg PA 90210-1111
123 Main St, Port St. Lucie PA 90210-1111';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);